Commit 7376af7a authored by Frank Winkler's avatar Frank Winkler
Browse files

Improved error detection for docker-compose --build.

parent e6b4c87d
docker network ls | grep pika-net > /dev/null || docker network create --driver bridge pika-net
docker-compose up -d --build
if [ $? -ne 0 ]; then
echo "Error: Cannot install pika-gui."
exit 1
fi
docker network ls | grep pika-net > /dev/null || docker network create --driver bridge pika-net
docker-compose up -d --build
if [ $? -ne 0 ]; then
echo "Error: Cannot install pika-influxdb."
exit 1
fi
#wait three seconds to finish mariadb in container
echo "Starting InfluxDB..."
......
docker network ls | grep pika-net > /dev/null || docker network create --driver bridge pika-net
docker-compose up -d --build
if [ $? -ne 0 ]; then
echo "Error: Cannot install containers for pika-mariadb and pika-adminer."
exit 1
fi
#wait three seconds to finish mariadb in container
echo "Starting MariaDB..."
......
Markdown is supported
0% or .
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment